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Overview

ICEfaces Eclipse Integration provides ICEfaces and ICEfaces facelets support for developers who use Eclipse IDE
for Java EE Developers (Galileo, v3.5) for ICEfaces application development. This integration extends Eclipse's
Web Tools Platform (WTP) and provides following extra features for ICEfaces support.

Installs ICEfaces, ICEfaces Facelets, and JSF Facelets Tools Incubator

Accesses a new ICEfaces Eclipse update site hosted on www.icefaces.org to provide a list of available
ICEfaces runtime libraries for use with the integration. Currently, ICEfaces 1.8.1 runtimes are available.
Future ICEfaces runtime library releases (1.8.2, etc.) can be directly accessed via this tool integration without
requiring uninstalling and re-installing the Eclipse integration itself.

Adds ICEfaces, ICEfaces Facelets, and dependent libraries to JSF projects

Configures project web.xml and faces-config.xml files for ICEfaces

Provides ICEfaces/Facelets friendly JSP/JSPX page templates

Adds ICEfaces components to the Eclipse Visual JSF Page Designer (part of JSF-JSP Editor)

Visual editing of JSF pages; Drag & drop components onto page, edit properties via properties editor, etc.

Requirements

1. Eclipse IDE for Java EE Developers v3.5 (Galileo)

This bundle includes required Eclipse WTP v3.1 (Web Tool Platform). It can be downloaded from
http://www .eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/galileor

2. ICEfaces- 1.8-Eclipse-3.5.0-plugins-v3.6.1.zip

This is core package of ICEfaces Eclipse Integration. It can be downloaded from

Installation

Uninstall previous release

Uninstall previous release of ICEfaces Integration for Eclipse can be done by Help -> About Eclipse
If ICEfaces Logo shows up in About Eclipse dialog, click Installation Detail


http://www.icefaces.org/main/downloads/os-downloads.iface
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After uninstall, restart Eclipse is required even though sometimes Apply Changes may work but it is recommended to
restart Eclipse prioro to proceding installation process.

Install ICEfaces Integration for Eclipse

Download and extract ICEfaces- 1.8-Eclipse-3.5.0-plugins-v3.6.1.zip to a local directory, for example,
C:\\icefaces.tools.update. After they are extracted, 2 sub-directories features and plugins are created as shown below.
-> ReadMe.pdf

-> ReleaseNotes.html

-> features

---> com.icesoft.ide.eclipse.icefaces.core.feature 3.6.1.200907151336

---> com.icesoft.ide.eclipse.icefaces.facelets.feature 3.6.0.200907151336

---> org.eclipse.jst.jsf.facelet.feature 0.2.0.200907151336

-> plugins

---> com.icesoft.ide.eclipse.designtime 3.6.1.200907151336

---> com.icesoft.ide.eclipse.icefaces.core_3.6.0.200907151336

---> com.icesoft.ide.eclipse.icefaces.doc_1.8.1.200907151336.jar

---> com.icesoft.ide.eclipse.icefaces.facelets.core_3.6.0.200907151336.jar

---> org.eclipse.jst.jsf.facelet.core_0.2.0.200907151336.jar

---> org.eclipse.jst.jsf.facelet.doc.user 0.2.0.200907151336.jar

---> org.eclipse.jst.jsf.facelet.tagsupport_0.1.0.200907151336.jar

---> org.eclipse.jst.jsf.facelet.ui 0.1.0.200907151336.jar



To install ICEfacs Integration for Eclipse Galileo
1.

Start Eclipse. From Eclipse main menu bar, select Help -> Install New Software... -> Add --> Local ...
2.

select C:\\icefaces.tools.update directory, where the zip files have been extracted in above step. And click Ok
& Add Site
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[_ CE ] [ Cancel ]

3. Ensure Group items by category is unchecked in Available Software wizard page (see screenshoot below)
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4. Check all features listed in the table as shown above:
o ICEfaces Eclipse Integration — Core

ICEfaces Facelets Eclipse Integration

JSF Facelets Tools Incubator

Cancel

o

o
5. Click Next and accepts Licences, finally click Finish. This step requires restart Eclipse.

Create new project with ICEfaces capabilities

The following instructions describe how to use how to create a new project with ICEfaces capabilities.
1. From Eclipse main menu bar, select File -> New -> Project...,
2

In New Project wizard, select Web -> Dynamic Web Project -> Next>

3. Type in project name, select Target Runtime. For Configurations, select ICEfaces project for standard
ICEfaces project; Select ICEfaces Facelets Project for ICEfaces facelets project. And click Next>.
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Dynamic Web Project =
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Project name: | ICEFacesProject |

Project contents
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In Web Module wizard page, be sure to check Generate web.xml deployment descriptor. Click Next>

ET.' New Dynamic Web Project ‘ |@®

Web Module —
Zonfigure web module settings. &

Contexk rook: | ICEfacesProject |

Content direckary: | WwebContent |

Generate web,xml deployment descriptor
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In JSF Capabilities wizard dialog, a download button available to download required JSF, ICEfaces, ICEfaces
supporting libraries. Click the button. See below
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JSF Configuration File: | I'WEB-IMF Faces-config. xml
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6. Once download button is clicked, you will noticed list of libraries available for you to download. Libraries
have to be downloaded one by one. ICEfaces Core library includes ICEfaces and depenent jar files which are

.:5 Download Library

Download Library 3
4
Select a library to download From the specified provider, &
Library Download Provider
ICEfaces Core Library v1.8.1 ICEsoft Technologies
ICEfaces Facelets Library w1.5.1 ICEsoft Technologies
ICEfaces Support Library +1.8.1 ICEsoft Technologies
J3F 1.2 {Apache MyFaces) Apache Software Foundation
J3F 1.2 {3un RI) 3un Microsystems
Standardized EL Library w1.0 ICEsoft Technologies
| 5
| Browse, ..
@ < Back Mext = Finish

normally not included in other libraries. ICEfaces Support Library includes required some Apache common
jar files. Those jar files are included in JSF 1.1 (Sun RI), JSF 1.1 (Apache MyFaces), and JSF 1.2 (Apache
MyFaces) so that you don't need it if you use JSF 1.1 (Sun RI), JSF 1.1 (Apache MyFaces), and JSF 1.2
(Apache MyFaces). Do not include ICEfaces Facelets Library if project is not ICEfaces facelets project.



-:5 New Dynamic Web Project

JSF Capabilities
Add J5F capabilities to this Weh Project

JSF Implementation Library

Type: |User Library w |
B, ICEFaces Core Library w1.8.1 ]
B ICEFaces Support Library w1.8.1 {@
=L I5F 1.2 (Sun RI) [%

l nﬂude libraries with this application

13F Configuration File: | S EE-INFIF aces-config, xml

J5F Servlet Mame: | Faces Servlet
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7. To download library, highligt JSF 1.2 (Sun RI) and click Next> to accept license and cllick Finish. Repeat the
same step for ICEfaces Core Library, and ICEfaces Support Library as well. After download, make sure to
check the checkbox of Includes libraries with this application. Click Next>.

8. ICEfaces library wizard. Click Next>

New Dynamic Web Project

ICEfaces configurations

ICEFaces project configurations :_" J

Create a ICEFaces sample page from template

ICEfaces sample page file name | ICEFacesPagel | (Extension is nat required)

web.xml
Conkexk Parameter

jawax.faces DEFALLT _SUFFIX JgspE W
com.icesoft, Faces. concurrentDOMViews :l
com.icesoft.Faces. synchronous pdate I:l
con.icesaft, Faces.uploadDireckary upload

com.icesoft, Faces,uploadMaxFileSize 4048576

Setvlet
com.icesoft,.Faces. webapp.xmlhttp, PersistentFacesserylest
com.icesoft, Faces, webapp, xmihttp, BlockingServlet
uploadSerwlet com.icesoft.Faces. component . inputfile. FilelploadServlet
Listener

El com.sun.faces. config. ConfigureListensr

@ Finish ] [ Cancel




9. Now you can click Finish button if ICEface facelet facet is not selected. Otherwise if Next> is enabled, clicke
Next> buuton to continue configure Facelets/ICEfaces facelets facet.
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Create ICEfaces friendly page with provided template

ICEfaces friendly JSP page templates are also provided in this integration to make your ICEfaces application
development easier. The following instructions describe how to use the provided template.

1. Right click on WebContent folder in Package Explorer view and select following menu items New >
JSP . (For ICEfaces facelets project, select menu New -> html to create xhtml file)

2. Type in jspx file name with extension .jspx and click Next>
Enter or select the parent folder:

ICEfacesProject WebContent
[

a4 2 ICEfacesProject
= .settings
- = build
= =rc
. = WebContent

File name: ICEfacesPage.jspx

@ <Back | Med¢> || Enish || Cancel




3. Select New ICEfaces JSPX File. Click Finish.

= Mew JavaServer Page m = ™

Select JSP Template -
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4. Current Eclipse release version v3.4 doesn't set JSP-JSP page editor (also called Visual JSF Page Designer,
Web Page Editor) as editor for jspx page. Forcing JSP-JSP page editor to load jspx file is required . See next
section “Use ICEfaces components in Visual JSF Page Designer”.

Use ICEfaces components in Visual JSF Page Designer

New Eclipse Visual JSF Page Designer has been added since Eclipse 3.3 as part of WTP 2.0. It provides an intuitive
close-to-WYSIWIG editing experience. It allows visually JSF page layout and components drag and drop. See
JavaServer Faces Tooling Developer Guide for detail. This integration includes ICEfaces components

design time support for Eclipse Visual JSF Page Designer. ICEfaces components palette view, property view for
ICEfaces components' attributes are both supported.

1. Use JSF-JSP editor for ICEfaces page. Current Eclipse release version v3.4 doesn't set JSP-JSP page editor as
editor for jspx page. Following the following instructions to open ICEfaces page in JSF-JSP editor.
e Right click on the ICEfaces jspx page
* Select Open with ->Other.., Select Web Page Editor, and click OK button
2. Select ICEfaces components in Palette view
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3. Edit ICEfaces component attributes in Property editor
[3_\ Problems | 4% Tasks | & Properties 2 4k Servers ﬁ Data Source Explorer| |5 Snippets = B

o
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Run ICEfaces application under Eclipse

After ICEfaces project is created, ICEfaces application and ICEfaces pages are developed, you should be able to
deploy and run on web container or application server. The way of deploying and running ICEfaces project onto
server is the same as other dynamic web projects. One thing you may need to pay attention is URL pattern to be used.
As an extension to JSF, ICEfaces provides its own version of the FacesServlet (Persistent Faces Servlet,
com.icesoft.faces.webapp.xmlhttp.PersistentFacesServlet) as well as an additional Servlet
(BlockingServlet) for handling asynchronous updates. The URL used to invoke ICEfaces page should follow the url
patterns for Persistent Faces Servlet instead of Faces Servlet defined in web.xml. By default ICEfaces tooling adds

* iface url-pattern for Persistent Faces Servlet as following

<servlet>
<servlet-name>Persistent Faces Servlet</servlet-name>
<servlet-class>

com.icesoft.faces.webapp.xmlhttp.PersistentFacesServliet

</servlet-class>
<load-on-startup> 1 </load-on-startup>

</servlet>

<servlet-mapping>
<servlet-name>Persistent Faces Servlet</servlet-name>
<url-pattern>*.iface</url-pattern>



</servlet-mapping>

In this case request url is http://hostname:port/web app name/IECfacesPagel.iface

As indicated in ICEfaces project configuration wizard, ICEfaces Eclipse Tooling actually adds a index.jsp and a
sample ICEfaces page (ICEfacesPagel.jspx by default). This index.jsp does nothing but forwards request to
ICEfacesPagel.iface.

Migrate ICEfaces project prom previous release

For ICEfaces project created by ICEfaces Integration for Eclipse Galileo v3.6.0, no action is required.

For ICEfaces project created by ICEfaces Integration for Eclipse Ganymede (v3.4.x) v3.5, following instructions
describe how to migrate the project to Eclipse Galileo (v3.5):

1. In Eclipse Galileo, File -> Import... -> General -> Existing Projects into workspace -> Next>
2. Follow Import wizard, select root directory of the project which is going to be imported.
3. Press Finish button

After the project is imported, you will notice errors in Problem view and these errors are all about broken library
references. These broken library references need to be fixed as described below.

1. Right click the project in Project Explorer view, click Build path -> Configure Build Path... which leads to
project properties dialog.
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2. Under Libraries tab, a list of libraries is shown with [missing JSF Library]



Java Build Path : : =7

| 2 Source | 2 Projects | =k Libraries | % Order and Export |
JARs and class folders on the build path:

== Apache Tomcat v6.0 [Apache Tomcat ve.0 [ Add JARs... ]
COm ft. [_ ]

o [ Add External JARs... ]
[ Add Variable... ]
ll Add Library... ]I

= CAR Loraries
=\ JRE System Library [jdk 1.6.0_13] [ R ]
- Web App Libraries [Add External Class Folder.., ]

% Edit...

Remaowe ]

=

Migrate JAR. File...

[ QK ] [ Cancel

Highlight these libraries and click Remove button

Press Add Libraries

Select User Library -> Next>

Select

1. ICEfaces Core Library

2. ICEfaces Facelets Library if and only if this is ICEfaces Facelets project

3. ICEfaces Support Library, it includes required Apache commons jar files. You don't need it if JSF 1.1
Sun RI or MyFaces 1.1 is selected.

4. JSF 1.2 (Sun RI) if runtime server doesn't include one.

VAW

& Add Library

User Library 5
Select alibrary to add to the classpath, EJ

User libraries;

[W] BhICEfaces Core Library v1.8.1 User Libraries. ..

[ =hICEfaces Facelets Library w1.8.1
[W] BhICEfaces Support Library v1.8.1
[W]BhISF 1.2 (Sun RI)

[ =hStandardized EL Library v 1.0

@ et = [ Finish H Cancel

7. Press Finish to return to project properties dialog.
8. Click Java EE module Dependencies and make sure libraries you just added are checked otherwise they will
not be deployed.



4::5 Properties for ICEfacesProject3s0
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Resource
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Java Build Fath
Java Code Style
Jawa Compiler
Java Editor
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Froject References
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This property page lets you add a Web Library dependency to utiity projects, JAR fles or
classpath entries. Archive dependencies will be resclved into the WEB-IMNF/{ib folder of the
web module at deployment ime. Class folder dependencies will be resolved into the WEB
-INFfclagses folder.

Select the utity project, JAR or classpath entry o add as a Web Library dependency

JAR Module Project
[] [k 1CEfaces Core Library w1.8.1 [CEfacesFroject3so
[V] [t ICEfaces Support Library v1.8.1  ICEfacesProject3so [ Select Al l
vELISE 1.2 (SunRI [CEfacesProject3so
M ¢ ) ] [ Deselect Al ]
| addms. |
[Add External JARs... ]
[ Add variable... ]
4 E
[% lRestore Defaults] [ Aoply ]
[ Ok ] ’ Cancel ]

9. Click OK buuton

10. Remove xmlhttp directory under WebContent (Optional).

11. Done.



	ICEfaces™ Integration For Eclipse Galileo V3.6.1
	Overview
	Requirements
	Installation
	Uninstall previous release
	Install ICEfaces Integration for Eclipse

	Create new project with ICEfaces capabilities
	Create ICEfaces friendly page with provided template
	Use ICEfaces components in Visual JSF Page Designer
	Run ICEfaces application under Eclipse
	Migrate ICEfaces project prom previous release


